Does anybody know how to reset code 37


Amoney

New member
Location
Orlando FL
I have a 2019 Alta redshift. I pressure washed it the other day and the error code 37 (moisture detected)service required came up. The bike still runs fine and charges fine. But I would like to reset the code. Does anybody know how?
 

Philip

Administrator
Staff member
Location
Ann Arbor, MI
It sounds like this code is not a fluke. It's probably a better idea to fix the moisture problem first before resetting the code. Else you might soon have to look for a new battery.
 

Amoney

New member
Location
Orlando FL
I put the bike under a cover with a dehumidifier. Also pulled off all the plugs. If I can reset the code I'll know if I got the moisture out. As long as it doesn't come back on. Any other suggestions?
 

Philip

Administrator
Staff member
Location
Ann Arbor, MI
I think it would be a good idea to remove the bottom cover, check the bladder for integrity, and replace the desiccant pack. Then you can clear the error code with a Multitool computer.

 

Amoney

New member
Location
Orlando FL
Thanks again phillip. Do you happen to have a link on where I can get the correct multi-tool computer or a link on how to use it, to reset the code? This is all new to me. Sorry for all the questions.
 

Dirt-E

Active member
Location
King George, VA
If you remove the bottom cover, be sure to get some replacement butyl rubber for the seal around the edge.

I would make sure you don't have any corrosion on your zero module. If you do, then you really want to make sure it's neutralized before closing it back up (in addition to the other recommended steps).
 

Similar threads

Top Bottom