Multitool issue


Hey just had a quick question Im trying to install and run the multitool on Pop os (basically ubuntu) and i go to run it and i have this pop up i followed the install instuctions but idk if i did them correctly as i am a Linux noob

beeofawesome@pop-os:~$ sudo redshift_multitool
[sudo] password for beeofawesome:
Traceback (most recent call last):
File "/usr/local/bin/redshift_multitool", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3251, in <module>
@_call_aside
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3235, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 585, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 791, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (rsa 4.9 (/usr/local/lib/python2.7/dist-packages/rsa-4.9-py2.7.egg), Requirement.parse('rsa==4.5'), set(['google-api-python-client']))


i can see that there is a version conflict of some kind but i dont know what do to do
Thanks to anyone who helps me out
 

Rashid510

Well-known member
Forum's Sponsor
You might need to update your python distrobution, ive had this same problem when trying to update older multitool laptops (could be that MT is old enough that Ubuntu libraries are not supporting it)
 

Similar threads

Top Bottom