ALTA MXR Display says: "Battery Vbat lo"


wwmotors

Well-known member
Likes
453
Location
Bavaria Germany
Hello Alta riders, one of my customers did not ride his 2018 MXR for a long time and forgot to care for the battery from time to time. No he has the following on the display: "Battery Vbat lo". The display shows the battery on zero percent. If he tries to charge, it says: "cycle key to clear battery error", but it does not help. Anyone had that issue?
I could not find something in the forum with the search function about that.
I have ALTA MT here. When someone can tell me wether MT can help here, then i would tell the customer to bring the bike the 250kms to my garage. Thanks guys.
Cheers WW
 

Rashid510

Well-known member
Forum's Sponsor
Likes
1,154
Location
South San Francisco, CA
Hello Alta riders, one of my customers did not ride his 2018 MXR for a long time and forgot to care for the battery from time to time. No he has the following on the display: "Battery Vbat lo". The display shows the battery on zero percent. If he tries to charge, it says: "cycle key to clear battery error", but it does not help. Anyone had that issue?
I could not find something in the forum with the search function about that.
I have ALTA MT here. When someone can tell me wether MT can help here, then i would tell the customer to bring the bike the 250kms to my garage. Thanks guys.
Cheers WW
Since I just recently dealt with this on a A based bike, potentially one of the modules has gone completely bad (the HVPCBA may have failed on the BRD side). If MT can be used this will clearly show the modules that are affected.
 

Similar threads

Top Bottom